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Abstract
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comments and questions.
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A.  Introduction

I.  Purpose of this document

This document introducesthe main featuresof Gmsh with simple and progressive
examples. It mainly focuses on the use of the Geometry and Mesh modules.

II.  Gmsh 

Gmshis an automatic3D finite elementmeshgeneratorwith build-in CAD and post-
processingfacilities. Its primal designgoal is to provide a simple meshingtool with
parametricinput and up to date visualizationcapabilities.One of its strengthsis the
ability to respecta characteristiclength field for the generationof adaptedmesheson
lines, surfaces and volumes, and to mix these meshes with simple structured grids. 
Gmsh is built aroundfour modules:geometry,mesh,solver and post-processing.The
specificationof anyinput to thesemodulesis doneeitherinteractivelyusingthegraphical
user interface or in ASCII text files using Gmsh's own scripting language.
 
This software is available under GPL license at http://www.geuz.org/gmsh
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B.  General presentation

I.  Launch Gmsh

To run Gmsh:
� type gmsh at your UNIX/Linux prompt
� double-click on the Gmsh icon for Window

II. The user interface

Upon running Gmsh, two windows are displayed:

These two windows are:
� the visualization window
� the menus window
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III.  Visualization window 

III.1.  Introduction

The visualization window is the area where the model (geometry or mesh) is displayed.
We can interact (rotate, move, zoom in/out, selection, ....) on it with the mouse.
By default the 3D axes orientation is defined such as the Z axis is perpendicalar to the
screen in the direction of the user.

III.2.  The tools and status bar

The tools and status bar gathers some visualization icons and displays some usefull
informations when you load a file or when the mouse is upon entities (vertices, curves,
surfaces, nodes, elements, etc ...). For instance, the coordinates and the ID of a point
could be displayed here.

� X : Displays in the YZ plane (Y=Z=0)
� Y : Displays in the ZX plane (Z=X=0)
� Z : Displays in the XY plane (X=Y=0)
� 1:1 : The display is set to unit scale
� ? : Shows current selected options in a separate window

III.3.  Basic mouse interaction

Mouse button Result

Left Rotation

Ctrl+Left Zoom window selection

Middle Zoom in/out

Rigth Pan

Ctrl+Right Reset the default viewpoint

Copyright Artenum SARL 2003, All rights  reserved                                                                                                   6/25



Spacecraft Plasma Interaction Analysis and Simulation Toolkit Date: 06/10/03

Gmsh User Tutorial for CAD and Meshing Issue: 1.0 Page 7

Note: the others mouse interaction functionality will be introduced in the examples.

IV.   Menus

IV.1.  Files

Allow to import and export geometry or mesh files, fixing appropriate options or format. 

IV.2.  Tools

By default, three sub menus (Options, visibility and statistics) allow you to 
Option : access and change Gmsh options (inculding rendering option of the visualisation
windows), 
Visibility : Define and manipulate the list of mesh/geometrical elements and group
(called Physical in Gmsh), you want to visualize.
Statistics : Which give a reduce set of statistics, mainly number of geometrical and mesh
element of a given type.

IV.3.  Helps

This menu give you acces to windows where list of mains short cut and options are
detailed. 

C.  Fundamental examples

I.  Breps approach

For the CAD part, Gmsh uses Breps approach. Breps means Boundary Representations.
In this approach a geometric model is defined and stored as a set of vertices, edges, faces
wich completely enclose its volume.
So the construction of a geometry is always based on a PLSV (Point, Line, Surface,
Volume) hierarchy coupled with operations like translation, rotation or extrusion.
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II.  2D examples

II.1.  Square

The first exampleshowshow to build a squareon the XY planeand how to meshthe
surface.This first exampleis moredetailedthantheothersto helptheuserto getusedto
Gmsh. Read it carefully if you want to understand the other examples.

II.1.a.  Geometry

 The obvious way

If you haveunderstoodthesimplephilosophyof Brepsapproach,thecreationof a square
will consist on :
� Entering 4 points
� Create 4 lines
� Declare a surface

So let's go !

STEP 1 : Entering point coordinates

Click on [Elementary] > [Add] > [New] > [Point] :

A contextual geometry window appears with the Point notebook selected:
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Enter the coordinates of Point 1 :
� X coordinate: 0
� Y coordinate: 0
� Z coordinate: 0
� Characteristic length: 1.0

The Characteristic lenght will define the size of the mesh around the point.

Click on [Add] and a point will be ploted on the visualization window.

 

     Tips & Tricks
� The [Return] key (keyboard) do the same thing that the [Add] button.
� If you put the mouse cursor over a point in the visualization window, its coordinates

and ID are displayed in the status bar.
� After pressing [Add], the geometry window is always here ready to get the next

coordinate.

Do the same for Points 2, 3 and 4 by introducing their coordinates in the geometry
window :

� Point 2: (10, 0, 0, 1.0)
� Point 3: (10, 10, 0, 1.0)
� Point 4: (0, 10, 0, 1.0)

STEP 2 : Drawing lines

Now, we are going to create lines between each points.
Click on [Straight line]  (the button just under [Point]).
A message appears in the status bar: Select start point ('q'=quit).
In order to draw the first line, select Point 1 by clicking on it with the first button of the
mouse.
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It becomes highlighted in red color.
A message appears in the status bar: Select end point ('q'=quit).
So, always with the first button of the mouse, select Point 2 (the end point).
A blue straight line is drawn.

A well known message appears in the status bar: Select start point ('q'=quit).
We proceedaspreviouslyseenfor linesbetween(Point 2 - Point3), (Point 3 – Point 4)
and (Point 4 – Point 1).
Once the square is drawn, just type 'q' for quitting the Straight line selection mode.

STEP 3 : Declaring surface 

So, we have a square but for Gmsh, it's only four lines. 
To declare a surface, click on [Plane surface].
A message appears in the status bar: Select exterior boundary ('q'=quit).
With the first button of the mouse select the first line (between Point 1 and Point 2).
The four lines become highlighted in red color and a message appears in the status bar:
Select hole boundary ('q'=quit).
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Since there is no hole in our simple square, just type 'q' for quitting the Plane surface
selection. The status bar shows that a plane surface was created.

Note: in our simple example, Gmsh has found the red closed curve alone. In more
complex cases, the user must select all the line one by one to create the line loop.

STEP 4: Visibility options

To ease the visualization of this surface, it is usefull to change some visibility options.
In the Gmsh menus, select [Tools] > [Options]. An option window appears.
From this option window, select Geometry in the left field and after click on the Visibility
notebook.
 

Select Surfaces (by default Points and Lines are already selected).
Select Point numbers, Line numbers and Surface numbers.

Click on [Apply] button and we may get something like that:
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The created surface is represented by a cross with dotted lines.
We can see the point ID, the line ID and the surface ID.

Note: In this example we have declared one surface but its ID is 6. Don't panic, you
haven't created 5 invisible surfaces ! It's only related to the internal numbering of
geometrical entities in Gmsh.

     Tips & Tricks
� If you want to keep your favorite options, just press the [Save] button in the option

window.These options will saved in a configuration file.

STEP 5: Saving the geometry

To save your masterpiece, select [File] > [Save as] in Gmsh menus and give it a name
without forgetting the .geo extension.
Here is the content of this file:

Copyright Artenum SARL 2003, All rights  reserved
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square.geo

Point(1) = {0, 0, 0, 1};
Point(2) = {10, 0, 0, 1};
Point(3) = {10, 10, 0, 1};
Point(4) = {0, 10, 0, 1};
Line (1) = {1, 2};
Line (2) = {2, 3};
Line (3) = {3, 4};
Line (4) = {4, 1};
Line Loop (1000006) = {2, 3, 4, 1};
Plane Surface (6) = {1000006};

If you quit Gmsh without saving your work, the current file is saved as unnamed.geo .

The translation function

With CAD tools, there is always several ways to draw something.
For example our square could be built using translation function.

As previously seen, create two points:

� Point 1: (0, 0, 0, 1.0)
� Point 2: (10, 0, 0, 1.0)

(with [Elementary] > [Add] > [New] > [Point])

Create a Straight line between them by clicking on [Straight line] :

 

Click on the backward arrow at the left of Geometry. 
Click on [Translate] > [Line]
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A contextual geometry definition window appears with the Translation notebook
selected:

Enter the vector components of the translation :
� X component: 0
� Y component: 10
� Z component: 0

Click on [Set] to validate this vector.
Follow the advice in the status bar: Select line ('q'=quit), by clicking on the line with the
left button of the mouse.
We get another line translated of 10 units in the XY plane and to the Y direction.
Once the translation is performed, just type 'q' for quitting the Translate selection mode.
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To finish your work, click twice on the little backward arrow at the left of Geometry to
change tools. Click on [Add] > [New] > [Straight line] and create lines between (Point 2
- Point 4),  and (Point 3 – Point 1).

For the last step, declare your surface by clicking on [Plane surface] and select it.
And don't forget to save your masterpiece by selecting [File] > [Save as] in Gmsh menus.
The saved file looks like this:

square.geo

Point(1) = {0,0,0,1.0};

Point(2) = {10,0,0,1.0};

Line(1) = {1,2};

Translate {0,10,0} {

  Duplicata { Line{1}; }

}

Line(3) = {2,4};

Line(4) = {3,1};

Line Loop(5) = {3,-2,4,1};

Plane Surface(6) = {5};

     Tips & Tricks
� If you want to generate a flat geometry only with simple entities without

transformations command, you can use in the [File] menu, [Save as] and choose in
the [Format] combobox: Gmsh unrolled geometry.
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A square with a hole

Now we are going to examine the case of a square with a triangular hole. The major
interest of this example is the declaration of the surface between these two polygons.

This task begins by creating a square. Now, it must be easy for you.
As previously done, just create a square with side length of 10 units without declaring the
surface (just points and lines).
After, create a triangle by entering those three points:

� Point 5: (3, 3, 0, 1.0)
� Point 6: (7, 3, 0, 1.0)
� Point 7: (3, 7, 0, 1.0)

And create the associated lines but not the surface. The final results looks like this:

Click on [Plane surface] and select the exterior boundary (as it is mentioned in the
status bar). 
Just pick with your mouse a side of the square, then the line loop becomes highlighted in
red color.
Another message appears in the status bar: Select hole boundary ('q'=quit).
Just pick with your mouse a side of the triangle, then the line loop of the triangle
becomes highlighted in red color.
Since there is no other hole in our square, just type 'q' for quitting the hole boundary
selection and  'q' again for quitting the Plane surface  selection.
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Finaly, save the geometry (square-hole.geo) by selecting [File] > [Save as] in Gmsh
menus.

square-hole.geo

Point(1) = {0, 0, 0, 1};
Point(2) = {10, 0, 0, 1};
Point(3) = {10, 10, 0, 1};
Point(4) = {0, 10, 0, 1};
Point(5) = {3, 3, 0, 1};
Point(6) = {7, 3, 0, 1};
Point(7) = {3, 7, 0, 1};
Line (1) = {1, 2};
Line (2) = {2, 3};
Line (3) = {3, 4};
Line (4) = {4, 1};
Line (5) = {5, 6};
Line (6) = {6, 7};
Line (7) = {7, 5};
Line Loop (1000010) = {2, 3, 4, 1, 6, 7, 5};
Plane Surface (10) = {1000010};

II.2.  Arcs

These examples shows how to build arcs on the XY plane 

II.2.a.  Circle arcs

Drawing a circle arc

Copyright Artenum SARL 2003, All rights  reserved
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A circle arc is defined by three points :

� The start point of the arc
� The center point of the arc
� The end point of the arc

The angular sector must be strictly smaller than Pi.

Click on [Elementary] > [Add] > [New] > [Point].
Enter the following points in the contextual geometry window :

� Point 1: (0, 0, 0, 1.0)
� Point 2: (10, 0, 0, 1.0)
� Point 3: (-7.07, 7.07, 0, 1.0)

Click on [Circle arc]

A message appears in the status bar: Select start point ('q'=quit)
Select the start point (Point 2) with the mouse.
Another message appears in the status bar: Select center point ('q'=quit)
Select the center point (Point 1) with the mouse.
Another message appears in the status bar: Select end point ('q'=quit)
Select the end point (Point 3) with the mouse and your arc is drawn.

Finaly, type 'q' for quitting the selection mode.

Drawing a circle

Thecircle geometricalentity doesn'texist in Gmsh.A circle mustbedrawnwith pieceof
arcs. At least with 3 arcs, but preferably with 4 arcs (it is easier to manage 90° angles).

Copyright Artenum SARL 2003, All rights  reserved
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To draw a circle in the XY plane, click on [Elementary] > [Add] > [New] > [Point].
Enter the following points in the contextual geometry window :

� Point 1: (2, 2, 0, 1.0)
� Point 2: (2, 0, 0, 1.0)
� Point 3: (4, 2, 0, 1.0)
� Point 4: (2, 4, 0, 1.0)
� Point 5: (0, 2, 0, 1.0)

Click on [Circle arc] and select the points with this order.

Start point Center point End point 

Point 2 Point 1 Point 3

Point 3 Point 1 Point 4

Point 4 Point 1 Point 5

Point 5 Point 1 Point 2

The result must look like this:
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circle.geo

Point(1) = {2, 2, 0, 1};
Point(2) = {2, 0, 0, 1};
Point(3) = {4, 2, 0, 1};
Point(4) = {2, 4, 0, 1};
Point(5) = {0, 2, 0, 1};
Circle (1) = {2, 1, 3} Plane{0, 0, 1};
Circle (2) = {3, 1, 4} Plane{0, 0, 1};
Circle (3) = {4, 1, 5} Plane{0, 0, 1};
Circle (4) = {5, 1, 2} Plane{0, 0, 1};

II.2.b.  Ellipse arcs

Drawing an ellipse arc

An ellipse arc is defined by four points :

� The start point of the arc
� The center point of the ellipse
� The major axis point of the ellipse (a point belonging to the major axis)
� The end point of the arc

The eccentric angle (the angular sector measured from the center) must be strictly smaller
than Pi.

Click on [Elementary] > [Add] > [New] > [Point].
Enter the following points in the contextual geometry window :

� Point 1: (0, 0, 0, 1.0)
� Point 2: (4, 0, 0, 1.0)
� Point 3: (1, 2, 0, 1.0)

Note: center point and the major axis point are the same but you can use four points if
you want.

Click on [Ellipse arc]
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A message appears in the status bar: Select start point ('q'=quit)
Select the start point (Point 2) with the mouse.
Another message appears in the status bar: Select center point ('q'=quit)
Select the center point (Point 1) with the mouse.
Another message appears in the status bar: Select major axis point ('q'=quit)
Select the major axis point (Point 1 again) with the mouse.
Another message appears in the status bar: Select end point ('q'=quit)
Select the end point (Point 3) with the mouse and your ellipse arc is drawn.

Finaly, type 'q' for quitting the selection mode.

Here is the source code:
ellipse-arc.geo

Point(1) = {0, 0, 0, 1};
Point(2) = {2, 0, 0, 1};
Point(3) = {0.5, 1, 0, 1};
Ellipse (1) = {2, 1, 1, 3} Plane{0, 0, 1};

Drawing an ellipse

As for thecircle, theellipsegeometricalentity doesn'texist in Gmsh.An ellipsemustbe
drawnwith pieceof arcs.At leastwith 3 arcs,but preferablywith 4 arcs(it is easierto
manage 90° angles).

To draw an ellipse in the XY plane, click on [Elementary] > [Add] > [New] > [Point].
Enter the following points in the contextual geometry window :

� Point 1: (2, 1, 0, 1.0)
� Point 2: (4, 2, 0, 1.0)
� Point 3: (4, 2, 0, 1.0)
� Point 4: (2, 4, 0, 1.0)
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� Point 5: (0, 2, 0, 1.0)

Click on [Ellipse arc] and select the points with this order.

Start point Center point Major axis point End point 

Point 2 Point 1 Point 1 Point 3

Point 3 Point 1 Point 1 Point 4

Point 4 Point 1 Point 1 Point 5

Point 5 Point 1 Point 1 Point 2

The result must look like this:

ellipse.geo

Point(1) = {2, 1, 0, 1};
Point(2) = {2, 0, 0, 1};
Point(3) = {4, 1, 0, 1};
Point(4) = {2, 2, 0, 1};
Point(5) = {0, 1, 0, 1};
Ellipse (1) = {2, 1, 1, 3} Plane{0, 0, 1};
Ellipse (2) = {3, 1, 1, 4} Plane{0, 0, 1};
Ellipse (3) = {4, 1, 1, 5} Plane{0, 0, 1};
Ellipse (4) = {5, 1, 1, 2} Plane{0, 0, 1};

II.3.  Spline

REMARK : IN THE CURENT VERSION OF SPIS/UI, SPLINE ARE NOT
SUPPORTED. DO NOT TRY TO IMPORT THEM IN THE CAD DATA
STRUCTURE.
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Spline curves implemented in Gmsh are Catmull-Rom splines. That is to say the curve
will pass trough all of the control points.

To draw an spline curve, click on [Elementary] > [Add] > [New] > [Point].
Enter the control points in the contextual geometry window :

� Point 1: (0, 6, 0, 1.0)
� Point 2: (4, 5, 0, 1.0)
� Point 3: (6, 3, 0, 1.0)
� Point 4: (9, 2, 0, 1.0)
� Point 5: (11, 4, 0, 1.0)

Click on [Spline] .

A message appears in the status bar: Select point (''e'=end, q'=quit)
Select the first point (Point 1) with the mouse.
The same message appears again in the status bar: Select point (''e'=end, q'=quit)
Select the second point (Point 2) with the mouse.
The same message appears again.
Etc ....
Finaly, type 'e' for ending the list of control points and 'q' for quitting the selection
mode.

Note: In this example we have declared one spline curve but its ID is 100000. Don't
panic, you haven't created 99999 other invisible curves ! It's only related to the internal
numbering of geometrical entities in Gmsh.
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II.4.  B-spline

REMARK : IN THE CURENT VERSION OF SPIS/UI, B-SPLINE ARE NOT
SUPPORTED. DO NOT TRY TO IMPORT THEM IN THE CAD DATA
STRUCTURE.

For the B-Spline, the curve doesn't pass through the control points by default. If you want
to force a curve to pass trough or nearer a control point, you must repeat its selection.

To draw an B-spline curve, click on [Elementary] > [Add] > [New] > [Point].
Enter the control points in the contextual geometry window :

� Point 1: (0, 3, 0, 1.0)
� Point 2: (2, 5, 0, 1.0)
� Point 3: (4, 1, 0, 1.0)
� Point 4: (7, 4, 0, 1.0)
� Point 5: (2, 2, 0, 1.0)

In the example below, we force the curve to pass trough the first and the last point by
repeating three time their selection.

Click on [B-Spline].
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A message appears in the status bar: Select point (''e'=end, q'=quit)
Select the first point (Point 1) with the mouse.
The same message appears again in the status bar: Select point (''e'=end, q'=quit)
Select the first point (Point 1) again and another one with the mouse.
The same message appears again in the status bar: Select point (''e'=end, q'=quit)
Select the second point (Point 2) with the mouse.
The same message appears again.
Etc ....
Select the last point (Point 5) with the mouse.
And select it again and another one.

Finaly, type 'e' for ending the list of control points and 'q' for quitting the selection
mode.

D.  Annexe A: Acronyms

ASCII American Standard Code for Information Interchange
Breps Boundary representations
CAD Computer Aided Design
GPL Gnu General Public License
PLSV Point Line Surface Volume 
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